Windows 7 RC1 Installed!

Tuesday, May 5, 2009

I finally got around to installing Windows 7 RC1 on my gaming rig last night. For starters, and I have no idea why, when the Press any key to boot from CD or DVD... prompts, my USB keyboard does not work, however prior to that and in the BIOS it does. So I ended up plugging a PS/2 keyboard for that step. I formatted my Raptor 74GB and installed Windows 7 RC1 there. The install was quick and it installed almost all my drivers right off the bat. My first boot into Windows 7 RC1 froze! I figured it was the eSATA (external hard drive) and unplugged it and rebooted. Once up and running I downloaded the latest Nvidia drivers for Windows 7 64-Bit as well as the motherboard drivers for Vista 64bit... they seem to be working for now! The next thing I did was point all the user shortcuts to my D drive. I like keeping as little data on my C drive so it runs faster and doesn't fill up, until I save up money for 2 300GB Raptors in Raid 0 :)

Also on a side note, I put all my hardware back to defaults (no overclocking). My Windows Experience Index is at 5.8 because of my Primary hard disk! The processor is at 6.2 (which I will get up tonight when I overclock back to 3.2Ghz). The Memory is at 6.3 as it is running at 800Mhz instead of 1066 (which I will get up tonight when I overclock). The graphics is at 6.4 and that is with a GTX 260! Tonight I will work on overclocking and installing all my apps again. I need to get my .mkv Bluray rips working (anyone have good codecs for Windows 7 yet?) Also might install a game or two to check it out.

Other than that, I customized the notification area to always showing me what's going on (pet peeve). I also enabled remote desktop and set a static IP for the box as I use it for connecting from outside. A cool feature/ bonus that I noticed in my 30 minutes of playing with Windows 7 is the slide show feature for the desktop backgrounds and the cool psychedelic backgrounds provided by Microsoft. Is Microsoft getting cool again?

Till next time,
Jorge Orchilles


No response to “Windows 7 RC1 Installed!”
Post a Comment | Post Comments (Atom)