Windows 7 and VMWare vSphere Client 4

Thursday, July 30, 2009

In my last Windows 7 blog post I wrote about an issue I was having running VMWare vSphere Client 4.0 on Windows 7 RTM 64 bit. Further research shows that this issue occurs in all versions of Windows 7. VMWare will most likely have to release a patch for their software as Windows 7 is now final. Thanks to this VMWare community post I was pointed to the right direction to fix it.

Problem
Although vSphere Client installs fine, when you try to connect to any server you get this error:
Error parsing the server "serverIP" "clients.xml" file. Login will continue, contact your system administrator.
Immediately followed by this error:
The type initializer for 'VirtualInfrastructure.Utils.HttpWebRequestProxy' threw an exception.
Solution
  1. Obtain a copy of C:\Program Files\Microsoft.NET\Framework\v2.0.50727\System.dll from a non Windows 7 machine that has .NET 3.5 SP1 installed. You can also download the file from here (recommended for step 3)
  2. Create a folder in the Windows 7 machine where the vSphere client is installed and copy the file from step 1 into this folder. For this example, create the folder under the vSphere client launcher installation directory and call it Lib+ (C:\Program Files (x86)\VMware\Infrastructure\Virtual Infrastructure Client\Launcher\Lib+) for 32 bit versions (C:\Program Files\VMware\Infrastructure\Virtual Infrastructure Client\Launcher\Lib+)
  3. Copy the VpxClient.exe.config from the zip in step 1 and put it in the "Launder" directory, overwriting the current file. What this is doing is adding a runtime option so you can run vSphere in developer mode.
  4. In the same "Launcher" directory (doesn't matter where really) right click and create a new "Text Document" and name it VpxClient.cmd (remove the .txt part) Open the file with notepad and for 64 bit put this in:
    @echo Off
    SET DEVPATH=%ProgramFiles(x86)%\VMware\Infrastructure\Virtual Infrastructure Client\Launcher\Lib+
    "%ProgramFiles(x86)%\VMware\Infrastructure\Virtual Infrastructure Client\Launcher\VpxClient.exe"
    For 32 bit:
    @echo Off
    SET DEVPATH=%ProgramFiles%\VMware\Infrastructure\Virtual Infrastructure Client\Launcher\Lib+
    "%ProgramFiles%\VMware\Infrastructure\Virtual Infrastructure Client\Launcher\VpxClient.exe"
  5. Thanks to the people on the VMWare communities forum that pointed me in the right direction for this. Hopefully VMWare comes out with a fix soon. For now this will do, it beats running a VM to administer other VM's :)

    Till Next Time,
    Jorge Orchilles

Comments

4 Responses to “Windows 7 and VMWare vSphere Client 4”
Post a Comment | Post Comments (Atom)

smark said...

Thanks, Jorge. This is exactly what I needed to get vSphere running in Windows 7!

I never would have figured this out in a million years. You're the man!

August 13, 2009 at 3:21 PM
Andy Fore said...

This was a great resource. One possible correction though, on my Windows Vista 32-bit install the dll file is located here:

"C:\Windows\Microsoft.NET\Framework\v2.0.50727\System.dll"

I checked my Windows XP install and it was also in the Windows directory path structure.

September 8, 2009 at 11:54 AM
Ing Pilo said...

Ist working

thanks a lot

March 5, 2010 at 1:10 PM
Anonymous said...

Installing viClient 2.5 and then vSphere 4 helps also.

vSphere uses vi2.5 libs to connect to legacy systems

June 22, 2010 at 3:42 AM